#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[A-Za-z][A-Za-z0-9.-]*@(?:aig\.com|abc\.in|abc\.uk))(?:,(?!$)|$))*$"
Local $sString = "abc@aig.com" & @CRLF & _
"abc@aig.com,xyz@abc.uk" & @CRLF & _
"abc@aig.com," & @CRLF & _
"abc@aig.com,xyz@abc.uk," & @CRLF & _
"xyz@aig.com,@xyz@abc.in,xyz@abc.uk" & @CRLF & _
"xyz@aig.com,xyz@abc.in,xyz@abc.uk" & @CRLF & _
"xyz@aig.com,xyz@abc.in,xyz@abc.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")