const regex = /^(?:(?:[A-Za-z][A-Za-z0-9.-]*@(?:aig\.com|abc\.in|abc\.uk))(?:,(?!$)|$))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[A-Za-z][A-Za-z0-9.-]*@(?:aig\\.com|abc\\.in|abc\\.uk))(?:,(?!$)|$))*$', 'gm')
const str = `abc@aig.com
abc@aig.com,xyz@abc.uk
abc@aig.com,
abc@aig.com,xyz@abc.uk,
xyz@aig.com,@xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}