re = /^(?:(?:[A-Za-z][A-Za-z0-9.-]*@(?:aig\.com|abc\.in|abc\.uk))(?:,(?!$)|$))*$/m
str = 'abc@aig.com
abc@aig.com,xyz@abc.uk
abc@aig.com,
abc@aig.com,xyz@abc.uk,
xyz@aig.com,@xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end