using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[A-Za-z][A-Za-z0-9.-]*@(?:aig\.com|abc\.in|abc\.uk))(?:,(?!$)|$))*$";
string input = @"abc@aig.com
abc@aig.com,xyz@abc.uk
abc@aig.com,
abc@aig.com,xyz@abc.uk,
xyz@aig.com,@xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}