$re = '/^(?:(?:[A-Za-z][A-Za-z0-9.-]*@(?:aig\.com|abc\.in|abc\.uk))(?:,(?!$)|$))*$/m';
$str = 'abc@aig.com
abc@aig.com,xyz@abc.uk
abc@aig.com,
abc@aig.com,xyz@abc.uk,
xyz@aig.com,@xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.uk
xyz@aig.com,xyz@abc.in,xyz@abc.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);