# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(@PROG\$\s+)\([A-Z]+\)/\1@PROG$/gm;t' <<< "Background (UNASSIGNED): Previous study of ours showed that @PROG$ (ALI) and C-reactive protein (CRP) are independent significant prognostic factors in operable non-small cell lung cancer (NSCLC) patients."