package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(@PROG\$\s+)\([A-Z]+\)`)
var str = `Background (UNASSIGNED): Previous study of ours showed that @PROG$ (ALI) and C-reactive protein (CRP) are independent significant prognostic factors in operable non-small cell lung cancer (NSCLC) patients.`
var substitution = "\1@PROG$"
fmt.Println(re.ReplaceAllString(str, substitution))
}