// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(@PROG\$\s+)\([A-Z]+\)").unwrap();
let string = "Background (UNASSIGNED): Previous study of ours showed that @PROG$ (ALI) and C-reactive protein (CRP) are independent significant prognostic factors in operable non-small cell lung cancer (NSCLC) patients.";
let substitution = "\\1@PROG$";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}