use strict;
my $str = 'Background (UNASSIGNED): Previous study of ours showed that @PROG$ (ALI) and C-reactive protein (CRP) are independent significant prognostic factors in operable non-small cell lung cancer (NSCLC) patients.';
my $regex = qr/(@PROG\$\s+)\([A-Z]+\)/mp;
my $subst = '\\1@PROG$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";