const regex = /{[^}]*"updated_at":"(?!2020-10-12)[^"]*"}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{[^}]*"updated_at":"(?!2020-10-12)[^"]*"}', 'g')
const str = `[{"id":"1","status":"0","created_at":"2020-10-12 12:00:00","updated_at":"2020-10-12 12:00:00"},{"id":"2","status":"1","created_at":"2020-10-13 12:00:00","updated_at":"2020-10-13 12:00:00"},
{"id":"3","status":"2","created_at":"2020-10-14 12:00:00","updated_at":"2020-10-14 12:00:00"}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}