re = /{[^}]*"updated_at":"(?!2020-10-12)[^"]*"}/
str = '[{"id":"1","status":"0","created_at":"2020-10-12 12:00:00","updated_at":"2020-10-12 12:00:00"},{"id":"2","status":"1","created_at":"2020-10-13 12:00:00","updated_at":"2020-10-13 12:00:00"},
{"id":"3","status":"2","created_at":"2020-10-14 12:00:00","updated_at":"2020-10-14 12:00:00"}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end