#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)TODAY([+-]\d+[DMY]){0,3}$"
Local $sString = "TODAY+12D-1M+3Y" & @CRLF & _
"TODAY-123D-1D-3Y" & @CRLF & _
"TODAY" & @CRLF & _
"" & @CRLF & _
"TODAY+1D6" & @CRLF & _
"TODAY+12D-1D+3Y+3D" & @CRLF & _
"TODAY+12X"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")