import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TODAY([+-]\\d+[DMY]){0,3}$";
final String string = "TODAY+12D-1M+3Y\n"
+ "TODAY-123D-1D-3Y\n"
+ "TODAY\n\n"
+ "TODAY+1D6\n"
+ "TODAY+12D-1D+3Y+3D\n"
+ "TODAY+12X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}