// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)TODAY([+-]\d+[DMY]){0,3}$").unwrap();
let string = "TODAY+12D-1M+3Y
TODAY-123D-1D-3Y
TODAY
TODAY+1D6
TODAY+12D-1D+3Y+3D
TODAY+12X";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}