$re = '/TODAY([+-]\d+[DMY]){0,3}$/m';
$str = 'TODAY+12D-1M+3Y
TODAY-123D-1D-3Y
TODAY
TODAY+1D6
TODAY+12D-1D+3Y+3D
TODAY+12X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);