re = /TODAY([+-]\d+[DMY]){0,3}$/m
str = 'TODAY+12D-1M+3Y
TODAY-123D-1D-3Y
TODAY
TODAY+1D6
TODAY+12D-1D+3Y+3D
TODAY+12X'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end