use strict;
my $str = 'TODAY+12D-1M+3Y
TODAY-123D-1D-3Y
TODAY
TODAY+1D6
TODAY+12D-1D+3Y+3D
TODAY+12X';
my $regex = qr/TODAY([+-]\d+[DMY]){0,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}