# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[.]([^.]*?)(?=[=.&]|$)/[\1]/g;t' <<< "a.b.c=17.5.2017&x.y=z"