using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[.]([^.]*?)(?=[=.&]|$)";
string substitution = @"[\1]";
string input = @"a.b.c=17.5.2017&x.y=z";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}