import Foundation
let pattern = #"[.]([^.]*?)(?=[=.&]|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a.b.c=17.5.2017&x.y=z"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)