re = /[.]([^.]*?)(?=[=.&]|$)/
str = 'a.b.c=17.5.2017&x.y=z'
subst = '[\\1]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result