#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[.]([^.]*?)(?=[=.&]|$)"
Local $sString = "a.b.c=17.5.2017&x.y=z"
Local $sSubst = "[\1]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)