$re = '/[.]([^.]*?)(?=[=.&]|$)/';
$str = 'a.b.c=17.5.2017&x.y=z';
$subst = "[\1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;