#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^,*(-?\d*\.?\d+)?(?:,+\g<1>)*,*$"
Local $sString = ",,,66,,78.8,-89.8,,0.0,,3.14," & @CRLF & _
"," & @CRLF & _
"67,89,10,0876,," & @CRLF & _
",,67.8,89.8787,78-89,-8,07,,33.33.33,,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")