const regex = /^,*(-?\d*\.?\d+)?(?:,+\g<1>)*,*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^,*(-?\\d*\\.?\\d+)?(?:,+\\g<1>)*,*$', 'gm')
const str = `,,,66,,78.8,-89.8,,0.0,,3.14,
,
67,89,10,0876,,
,,67.8,89.8787,78-89,-8,07,,33.33.33,,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}