import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^,*(-?\\d*\\.?\\d+)?(?:,+\\g<1>)*,*$";
final String string = ",,,66,,78.8,-89.8,,0.0,,3.14,\n"
+ ",\n"
+ "67,89,10,0876,,\n"
+ ",,67.8,89.8787,78-89,-8,07,,33.33.33,,,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}