import re
regex = re.compile(r"^,*(-?\d*\.?\d+)?(?:,+\g<1>)*,*$", flags=re.MULTILINE)
test_str = (",,,66,,78.8,-89.8,,0.0,,3.14,\n"
",\n"
"67,89,10,0876,,\n"
",,67.8,89.8787,78-89,-8,07,,33.33.33,,,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")