$re = '/^,*(-?\d*\.?\d+)?(?:,+\g<1>)*,*$/m';
$str = ',,,66,,78.8,-89.8,,0.0,,3.14,
,
67,89,10,0876,,
,,67.8,89.8787,78-89,-8,07,,33.33.33,,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);