use strict;
my $str = ',,,66,,78.8,-89.8,,0.0,,3.14,
,
67,89,10,0876,,
,,67.8,89.8787,78-89,-8,07,,33.33.33,,,';
my $regex = qr/^,*(-?\d*\.?\d+)?(?:,+\g<1>)*,*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}