#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\S\d]+)@(\S+)[.](\S+.?\S+)$"
Local $sString = "dilip@heraldcollege.edu.np" & @CRLF & _
"dilip1234@heraldcollege.edu.np" & @CRLF & _
"Dilip1234 pokhrel@heraldcollege.edu.np" & @CRLF & _
"canshu911@gmail.com" & @CRLF & _
"canshu0101@gmail.com" & @CRLF & _
"np03cs4s220091@heraldcollege.edu.np"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")