import Foundation
let pattern = #"^([\S\d]+)@(\S+)[.](\S+.?\S+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dilip@heraldcollege.edu.np
dilip1234@heraldcollege.edu.np
Dilip1234 pokhrel@heraldcollege.edu.np
canshu911@gmail.com
canshu0101@gmail.com
np03cs4s220091@heraldcollege.edu.np
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)