import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\S\\d]+)@(\\S+)[.](\\S+.?\\S+)$";
final String string = "dilip@heraldcollege.edu.np\n"
+ "dilip1234@heraldcollege.edu.np\n"
+ "Dilip1234 pokhrel@heraldcollege.edu.np\n"
+ "canshu911@gmail.com\n"
+ "canshu0101@gmail.com\n"
+ "np03cs4s220091@heraldcollege.edu.np";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}