$re = '/^([\S\d]+)@(\S+)[.](\S+.?\S+)$/m';
$str = 'dilip@heraldcollege.edu.np
dilip1234@heraldcollege.edu.np
Dilip1234 pokhrel@heraldcollege.edu.np
canshu911@gmail.com
canshu0101@gmail.com
np03cs4s220091@heraldcollege.edu.np';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);