const regex = new RegExp('^([\\S\\d]+)@(\\S+)[.](\\S+.?\\S+)$', 'gm')
const str = `dilip@heraldcollege.edu.np
dilip1234@heraldcollege.edu.np
Dilip1234 pokhrel@heraldcollege.edu.np
canshu911@gmail.com
canshu0101@gmail.com
np03cs4s220091@heraldcollege.edu.np`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}