package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\S\d]+)@(\S+)[.](\S+.?\S+)$`)
var str = `dilip@heraldcollege.edu.np
dilip1234@heraldcollege.edu.np
Dilip1234 pokhrel@heraldcollege.edu.np
canshu911@gmail.com
canshu0101@gmail.com
np03cs4s220091@heraldcollege.edu.np`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}