#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Za-z0-9]{17}|[A-Za-z0-9]{8}[*_][A-Za-z0-9]{2})$"
Local $sString = "5UXWX7C56BA12345" & @CRLF & _
" False False " & @CRLF & _
"5UXWX7C56BA123456" & @CRLF & _
" True True " & @CRLF & _
"5UXWX7C56BA1234569" & @CRLF & _
" True False UNEXPECTED" & @CRLF & _
"5UXWX7C5*B" & @CRLF & _
" False False " & @CRLF & _
"5UXWX7C5*BA" & @CRLF & _
" True True " & @CRLF & _
"5UXWX7C5*BA1" & @CRLF & _
" False False " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")