using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Za-z0-9]{17}|[A-Za-z0-9]{8}[*_][A-Za-z0-9]{2})$";
string input = @"5UXWX7C56BA12345
False False
5UXWX7C56BA123456
True True
5UXWX7C56BA1234569
True False UNEXPECTED
5UXWX7C5*B
False False
5UXWX7C5*BA
True True
5UXWX7C5*BA1
False False
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}