import re
regex = re.compile(r"^(?:[A-Za-z0-9]{17}|[A-Za-z0-9]{8}[*_][A-Za-z0-9]{2})$", flags=re.MULTILINE)
test_str = ("5UXWX7C56BA12345\n"
" False False \n"
"5UXWX7C56BA123456\n"
" True True \n"
"5UXWX7C56BA1234569\n"
" True False UNEXPECTED\n"
"5UXWX7C5*B\n"
" False False \n"
"5UXWX7C5*BA\n"
" True True \n"
"5UXWX7C5*BA1\n"
" False False \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")