// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[A-Za-z0-9]{17}|[A-Za-z0-9]{8}[*_][A-Za-z0-9]{2})$").unwrap();
let string = "5UXWX7C56BA12345
False False
5UXWX7C56BA123456
True True
5UXWX7C56BA1234569
True False UNEXPECTED
5UXWX7C5*B
False False
5UXWX7C5*BA
True True
5UXWX7C5*BA1
False False
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}