const regex = /^(?:[A-Za-z0-9]{17}|[A-Za-z0-9]{8}[*_][A-Za-z0-9]{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[A-Za-z0-9]{17}|[A-Za-z0-9]{8}[*_][A-Za-z0-9]{2})$', 'gm')
const str = `5UXWX7C56BA12345
False False
5UXWX7C56BA123456
True True
5UXWX7C56BA1234569
True False UNEXPECTED
5UXWX7C5*B
False False
5UXWX7C5*BA
True True
5UXWX7C5*BA1
False False
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}