package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bLOST\s+\$(?:0|[1-9]\d*)\.\d{2}\b|\$(?<NUMBER>(?:0|[1-9]\d*)\.\d{2})\b`)
var str = `I PAID $10.12 FOR THE BEER
I LOST $11.34 IN THE GAME
I LOST $11.34 IN THE GAME AND PAID $10.12 FOR THE BEER
I PAID $0.12 FOR THE BEER
I DISLOST $11.34 IN THE GAME
I PAID $04.12 FOR THE BEER
I PAID $10.126 FOR THE BEER
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}