use strict;
my $str = 'I PAID $10.12 FOR THE BEER
I LOST $11.34 IN THE GAME
I LOST $11.34 IN THE GAME AND PAID $10.12 FOR THE BEER
I PAID $0.12 FOR THE BEER
I DISLOST $11.34 IN THE GAME
I PAID $04.12 FOR THE BEER
I PAID $10.126 FOR THE BEER
';
my $regex = qr/\bLOST\s+\$(?:0|[1-9]\d*)\.\d{2}\b|\$(?<NUMBER>(?:0|[1-9]\d*)\.\d{2})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}