import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bLOST\\s+\\$(?:0|[1-9]\\d*)\\.\\d{2}\\b|\\$(?<NUMBER>(?:0|[1-9]\\d*)\\.\\d{2})\\b";
final String string = "I PAID $10.12 FOR THE BEER\n"
+ "I LOST $11.34 IN THE GAME\n"
+ "I LOST $11.34 IN THE GAME AND PAID $10.12 FOR THE BEER\n"
+ "I PAID $0.12 FOR THE BEER\n"
+ "I DISLOST $11.34 IN THE GAME\n"
+ "I PAID $04.12 FOR THE BEER\n"
+ "I PAID $10.126 FOR THE BEER\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}