// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bLOST\s+\$(?:0|[1-9]\d*)\.\d{2}\b|\$(?<NUMBER>(?:0|[1-9]\d*)\.\d{2})\b").unwrap();
let string = "I PAID $10.12 FOR THE BEER
I LOST $11.34 IN THE GAME
I LOST $11.34 IN THE GAME AND PAID $10.12 FOR THE BEER
I PAID $0.12 FOR THE BEER
I DISLOST $11.34 IN THE GAME
I PAID $04.12 FOR THE BEER
I PAID $10.126 FOR THE BEER
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}