import Foundation
let pattern = #"\bLOST\s+\$(?:0|[1-9]\d*)\.\d{2}\b|\$(?<NUMBER>(?:0|[1-9]\d*)\.\d{2})\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I PAID $10.12 FOR THE BEER
I LOST $11.34 IN THE GAME
I LOST $11.34 IN THE GAME AND PAID $10.12 FOR THE BEER
I PAID $0.12 FOR THE BEER
I DISLOST $11.34 IN THE GAME
I PAID $04.12 FOR THE BEER
I PAID $10.126 FOR THE BEER
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)