$re = '/\bLOST\s+\$(?:0|[1-9]\d*)\.\d{2}\b|\$(?<NUMBER>(?:0|[1-9]\d*)\.\d{2})\b/m';
$str = 'I PAID $10.12 FOR THE BEER
I LOST $11.34 IN THE GAME
I LOST $11.34 IN THE GAME AND PAID $10.12 FOR THE BEER
I PAID $0.12 FOR THE BEER
I DISLOST $11.34 IN THE GAME
I PAID $04.12 FOR THE BEER
I PAID $10.126 FOR THE BEER
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);