#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\*\*Type de client\*\*[\s\S]*?)(?=\n\n\s*\nEst-ce que c'est une mission qui peut t'intéresser \?)"
Local $sString = "Hello Guillaume," & @CRLF & _
"" & @CRLF & _
"Une nouvelle mission vient de tomber sur Impli et je pense qu'elle peut t'intéresser :" & @CRLF & _
"" & @CRLF & _
"**Titre de la mission** : Expert Make - Isabelle GODEFROY" & @CRLF & _
"" & @CRLF & _
"**Type de client** :" & @CRLF & _
"" & @CRLF & _
"**Nombre d'employés** :" & @CRLF & _
"" & @CRLF & _
"**Outil(s)** : Make" & @CRLF & _
"" & @CRLF & _
"**Type de mission** :" & @CRLF & _
"" & @CRLF & _
"**Début de la mission** :" & @CRLF & _
"" & @CRLF & _
"**Budget indicatif** : 500 à 1 000 euros" & @CRLF & _
"" & @CRLF & _
"**Description** : " & @CRLF & _
"" & @CRLF & _
"Apprendre à interconnecter les outils : Zoom, gmail, contrat/attestations" & @CRLF & _
"" & @CRLF & _
"google form ( évaluation, positionnement..),google agenda, Calendly." & @CRLF & _
"" & @CRLF & _
"En lien aussi avec Teachizy (plateforme LMS)." & @CRLF & _
"" & @CRLF & _
"Merci" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Est-ce que c'est une mission qui peut t'intéresser ?" & @CRLF & _
"" & @CRLF & _
"Si oui alors il suffit juste à répondre à cet e-mail pour une mise en relation 🙂" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Merci," & @CRLF & _
"" & @CRLF & _
"Edouard"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")