$re = '/(\*\*Type de client\*\*[\s\S]*?)(?=\n\n\s*\nEst-ce que c\'est une mission qui peut t\'intéresser \?)/';
$str = 'Hello Guillaume,
Une nouvelle mission vient de tomber sur Impli et je pense qu\'elle peut t\'intéresser :
**Titre de la mission** : Expert Make - Isabelle GODEFROY
**Type de client** :
**Nombre d\'employés** :
**Outil(s)** : Make
**Type de mission** :
**Début de la mission** :
**Budget indicatif** : 500 à 1 000 euros
**Description** :
Apprendre à interconnecter les outils : Zoom, gmail, contrat/attestations
google form ( évaluation, positionnement..),google agenda, Calendly.
En lien aussi avec Teachizy (plateforme LMS).
Merci
Est-ce que c\'est une mission qui peut t\'intéresser ?
Si oui alors il suffit juste à répondre à cet e-mail pour une mise en relation 🙂
Merci,
Edouard';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);