# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\*\*Type de client\*\*[\s\S]*?)(?=\n\n\s*\nEst-ce que c'est une mission qui peut t'intéresser \?)"
test_str = ("Hello Guillaume,\n\n"
"Une nouvelle mission vient de tomber sur Impli et je pense qu'elle peut t'intéresser :\n\n"
"**Titre de la mission** : Expert Make - Isabelle GODEFROY\n\n"
"**Type de client** :\n\n"
"**Nombre d'employés** :\n\n"
"**Outil(s)** : Make\n\n"
"**Type de mission** :\n\n"
"**Début de la mission** :\n\n"
"**Budget indicatif** : 500 à 1 000 euros\n\n"
"**Description** : \n\n"
"Apprendre à interconnecter les outils : Zoom, gmail, contrat/attestations\n\n"
"google form ( évaluation, positionnement..),google agenda, Calendly.\n\n"
"En lien aussi avec Teachizy (plateforme LMS).\n\n"
"Merci\n\n"
" \n\n"
"Est-ce que c'est une mission qui peut t'intéresser ?\n\n"
"Si oui alors il suffit juste à répondre à cet e-mail pour une mise en relation 🙂\n\n"
" \n\n"
"Merci,\n\n"
"Edouard")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.