use strict;
my $str = 'Hello Guillaume,
Une nouvelle mission vient de tomber sur Impli et je pense qu\'elle peut t\'intéresser :
**Titre de la mission** : Expert Make - Isabelle GODEFROY
**Type de client** :
**Nombre d\'employés** :
**Outil(s)** : Make
**Type de mission** :
**Début de la mission** :
**Budget indicatif** : 500 à 1 000 euros
**Description** :
Apprendre à interconnecter les outils : Zoom, gmail, contrat/attestations
google form ( évaluation, positionnement..),google agenda, Calendly.
En lien aussi avec Teachizy (plateforme LMS).
Merci
Est-ce que c\'est une mission qui peut t\'intéresser ?
Si oui alors il suffit juste à répondre à cet e-mail pour une mise en relation 🙂
Merci,
Edouard';
my $regex = qr/(\*\*Type de client\*\*[\s\S]*?)(?=\n\n\s*\nEst-ce que c'est une mission qui peut t'intéresser \?)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}